Jump to content


Photo

AQUAS Water asset: no reflection


  • Please log in to reply
2 replies to this topic

#1 Birdie

Birdie

    Advanced Member

  • Members
  • PipPipPip
  • 430 posts

Posted 22 March 2019 - 09:20 AM

So I got this asset, it generally works. But the reflection seems not to work and I have to remove the option/script to make the water show in game.
Does somebody know what it needs to make the reflection of this asset work? Is it just a setting in Unity or can it only be achieved by editing of scripts or shaders?

Iirc I think the creator of the reflective patch said he implemented the AQUAS reflection or so? Maybe he can turn some light on this...

#2 Stingreye

Stingreye

    Advanced Member

  • Members
  • PipPipPip
  • 337 posts
  • LocationSouthern California

Posted 09 January 2021 - 05:32 PM

Birdie I know this is old. But the simple answer is that unity asset bundles do not pass scripts to PG. so the script would need to be add on PG’s end. It’s a limitation of the asset bundle system.

#3 Birdie

Birdie

    Advanced Member

  • Members
  • PipPipPip
  • 430 posts

Posted 09 January 2021 - 11:59 PM

Birdie I know this is old. But the simple answer is that unity asset bundles do not pass scripts to PG. so the script would need to be add on PG’s end. It’s a limitation of the asset bundle system.

In the meantime i already learned that and so just use the onboard water4advanced material and its working reflection. I even think it's on par with the AQUAS when setup with love and a lot of existing courses would benefit from it if the designer would exchange the material. Sure always with a possible performance hit in mind. But one more word regarding scripts, i now always check the package content before buying an asset if there are some scripts included which eventually would make the asset not work properly for the reason you described.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users