Jump to content


Photo

What you see (in Unity) is not what you get (in Game)


Best Answer Stingreye , 08 April 2020 - 09:04 PM

make sure you do not have dynamic skies on in game or it will ignore that lighting setting I think.

Go to the full post


  • Please log in to reply
9 replies to this topic

#1 pctyoyo

pctyoyo

    Member

  • Members
  • PipPip
  • 10 posts

Posted 07 April 2020 - 01:56 AM

The colors you see in Unity don't match the colors you see in the Game.  Below are two images from a rough course using stock textures.  The first is taken in Unity's Scene view, the second is in Unity's Game view:

uyyhNd3.png

CnKwpjb.png

 

As you can see, in Game view, colors of textures, trees and sky are brighter and washed out.

When actually playing the game, adjusting the various Graphics Settings sliders does not help.

Most of the wonderful courses from experienced designers that I download and play have little or none of the washed out effect found in my image/course.

Here's my (very broad) question:  How do you folks deal with color differences between Unity and the Game?

Thank you,

David



#2 DPRoberts

DPRoberts

    Advanced Member

  • Members
  • PipPipPip
  • 1,534 posts

Posted 07 April 2020 - 02:43 AM

.

#3 DPRoberts

DPRoberts

    Advanced Member

  • Members
  • PipPipPip
  • 1,534 posts

Posted 07 April 2020 - 02:45 AM

What you see in the editor in "Game view" is fairly close to what you will see in PG. I would suggest moving the Main Camera around and check the Game view when handling color adjustments.

I find that the normals never seem to "pop" as much in game so I would push them a little further in Unity than you like. Additionally, I find that the extreme white in PG game is a bit brighter for me than appears in the "Game view" but that could be my in game settings. So, I try not to have too many white areas that "blow out". Mostly watch bunkers and clouds for this.

You will have to experiment a bit with Lighting and the directional light to improve some of the washed out look.

#4 Dropzone73

Dropzone73

    Advanced Member

  • Members
  • PipPipPip
  • 539 posts
  • LocationFinland

Posted 07 April 2020 - 06:56 AM

Also a good idea is to make all the tertures quite dark. The game washes too bright textures.

And fefore building the course, downscale the directional light's intensity. Lighting must be darker in Unity to be good in the game.



#5 pctyoyo

pctyoyo

    Member

  • Members
  • PipPip
  • 10 posts

Posted 07 April 2020 - 09:09 PM

Thank you both for the replies.  I have been experimenting today with the Directional Light "Intensity" setting.  When lowering

that from the default of .85 down to .4, or even .1, I see a drastic change (darkening) within Unity's Game view, but after compiling the course

and opening it in JNPG,  the change is not there, it's just as washed out as ever.  Is this normal?  

Thank you!



#6 Dropzone73

Dropzone73

    Advanced Member

  • Members
  • PipPipPip
  • 539 posts
  • LocationFinland

Posted 08 April 2020 - 11:51 AM

It's not normal.

What kind of lighting settings you have? I'm not talking about directional light now.

Print screens of both of them would be nice.

 

And remember my advice about darkening your textures. It's smart to do anyway, trust me!



#7 pctyoyo

pctyoyo

    Member

  • Members
  • PipPip
  • 10 posts

Posted 08 April 2020 - 07:04 PM

Not normal - interesting.  As I said in my original post, the washed out issue really only seems to occur with courses I build.  While I of course don't have other designer's Unity Projects to compare with, the colors of their courses in JNPG are generally very good.  Mine aren't.  And that's everything - textures, vegetation and skies. So it very well could be a lighting issue.

Here's my Directional Light settings in the Inspector, and the settings in Window>Light:

C2wcHag.png

OoQCRZP.png

My JNPG Graphics settings are the default Ultra High settings for testing purposes.

 

I start all my courses from a flattened, treeless version of MJ's Course1 that comes with CF.   I haven't changed any settings,

and only started experimenting with the Directional Light settings yesterday.  Once I get the lighting straightened out, then I'll see about darkening textures :)



#8 Stingreye

Stingreye

    Advanced Member

  • Members
  • PipPipPip
  • 305 posts
  • LocationSouthern California

Posted 08 April 2020 - 09:04 PM   Best Answer

make sure you do not have dynamic skies on in game or it will ignore that lighting setting I think.



#9 Dropzone73

Dropzone73

    Advanced Member

  • Members
  • PipPipPip
  • 539 posts
  • LocationFinland

Posted 08 April 2020 - 09:20 PM

I see nothing wrong or weird in your values.

Hopefully someone other comes up with some good ideas.

 

PS. Stingreye already came with a good point. That must be it.



#10 pctyoyo

pctyoyo

    Member

  • Members
  • PipPip
  • 10 posts

Posted 09 April 2020 - 03:41 PM

Yep Stingreye. you were right.  With Dynamic Skies On, that lighting setting in Unity does not make it into the game.  With Dynamic Skies Off, it does.  Looks like I can drop that Intensity setting down to around 0.6, and get a much closer color match between Unity and the game in JNPG.

Thank you all for the help - I really appreciate it!  

David


  • Dropzone73 and Stingreye like this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users